Some REST API endpoints are timing out

Incident Report for MODE

Resolved

We have identified the root cause that has been impacting both the REST API service as well as the MQTT service. We have made changes to our system to mitigate the impact. The REST API service is now operating normally.
Posted Jan 30, 2025 - 00:20 PST

Investigating

We observed that some REST API endpoints are currently taking too long to complete, or timing out completely. This may also impact the user experience on the BizStack Console. The issue may be related to the ongoing MQTT service issue. We are investigating.
Posted Jan 29, 2025 - 20:15 PST
This incident affected: REST API Service and BizStack Console.